Maximo Open Forum

Expand all | Collapse all

BMXAA5480E-Report run error

  • 1.  BMXAA5480E-Report run error

    Posted 07-15-2020 10:48
    Hello! I'm hoping this extremely esteemed collaborative of knowledge can help me out with a reporting issue that's been occurring for a few months now. 

    We're running Maximo 7.6.0.6 on an on-site server.

    I've got a scheduled work order report that's been throwing the following error each time it's scheduled to run:

    [WOTRACK] WOTRACK_ABRIGGS_1501077413.rptdesign psdi.util.MXApplicationException: BMXAA5480E - The report WOTRACK_ABRIGGS_1501077413.rptdesign of the WOTRACK application failed to run. Error happened while running the report. at com.ibm.tivoli.maximo.report.birt.admin.ReportAdminService.runReport(ReportAdminService.java:3342) at com.ibm.tivoli.maximo.report.birt.admin.ReportAdminService.runReport(ReportAdminService.java:3260) at com.ibm.tivoli.maximo.report.birt.queue.ReportQueueManager.runQueuedReport(ReportQueueManager.java:933) at com.ibm.tivoli.maximo.report.birt.queue.ReportQueueManager.runQueuedReport(ReportQueueManager.java:857) at com.ibm.tivoli.maximo.report.birt.queue.ReportQueueManager.doWork(ReportQueueManager.java:659) at com.ibm.tivoli.maximo.report.birt.queue.ReportQueueManager$ReportRunThread.attemptToRunReport(ReportQueueManager.java:514) at com.ibm.tivoli.maximo.report.birt.queue.ReportQueueManager$ReportRunThread.run(ReportQueueManager.java:453) Caused by: com.ibm.tivoli.maximo.report.birt.runtime.ReportExecutionException: Error happened while running the report. at com.ibm.tivoli.maximo.report.birt.engine.MXReportEngine.executeReport(MXReportEngine.java:422) at com.ibm.tivoli.maximo.report.birt.engine.MXReportEngine.executeReport(MXReportEngine.java:144) at com.ibm.tivoli.maximo.report.birt.admin.ReportAdminService.runReport(ReportAdminService.java:3307) ... 6 more Caused by: com.ibm.tivoli.maximo.report.birt.runtime.ReportExecutionException: Error happened while running the report. at com.ibm.tivoli.maximo.report.birt.runtimeprovider.XLSReportGenerator.generateReport(XLSReportGenerator.java:117) at com.ibm.tivoli.maximo.report.birt.runtimeprovider.ReportExecutionTaskImpl.executeReport(ReportExecutionTaskImpl.java:133) at com.ibm.tivoli.maximo.report.birt.engine.MXReportEngine.executeReport(MXReportEngine.java:399) ... 8 more Caused by: org.eclipse.birt.report.engine.api.EngineException: Error happened while running the report. at org.eclipse.birt.report.engine.api.impl.EngineTask.handleFatalExceptions(EngineTask.java:2363) at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:191) at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.run(RunAndRenderTask.java:77) at com.ibm.tivoli.maximo.report.birt.runtimeprovider.XLSReportGenerator.generateReport(XLSReportGenerator.java:111) ... 10 more Caused by: java.lang.NullPointerException at uk.co.spudsoft.birt.emitters.excel.ExcelEmitter.end(ExcelEmitter.java:273) at org.eclipse.birt.report.engine.emitter.CompositeContentEmitter.end(CompositeContentEmitter.java:65) at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:183) ... 12 more

    Any ideas what's causing this, and what I can do to fix it? I've tried deleting the scheduled report, and creating a new scheduled instance, but that didn't help. I tried changing the file attachment format from .xlsx to .xls, and that didn't help.

    Suggestions and/or solutions are welcomed! :)

    Thanks,
    Amy


    #Reporting

    ------------------------------
    Maintenance Planner
    The Jackson Laboratory
    Bar Harbor, ME
    207-288-6356
    ------------------------------


  • 2.  RE: BMXAA5480E-Report run error

    Posted 07-15-2020 15:43

    I'm going to apologize as I'm mostly going to ask additional questions. It's helpful to help narrow down what the problem might be. 

    Does the report work when you run it manually? If so, does it work when you export to Excel manually? Based on where the error is occurring, I would expect it would have similar issues but we've seen bugs before that are specific to scheduled reports.

    Can you export it to PDF? While the XLSX & XLS formats are different, PDF tends to be the most reliable for exports so it's good to see if the issue might be specific to exporting to Excel.

    Are you displaying any rich text fields (such as long description) in the report? When the long descriptions have complex HTML we've seen issues executing a report. For the records you expect to be returned in the report, it would be good to review any rich text fields to see if there's anything unusual. For example, we've seen people copy & paste entire websites into a long description on a PO.



    ------------------------------
    Steven Shull
    Projetech
    ------------------------------



  • 3.  RE: BMXAA5480E-Report run error

    Posted 07-16-2020 07:34
      |   view attached
    Hi Steven - thanks for responding!

    Yes, the report works when I run it manually; and the Excel export works too. 

    I'll try a scheduled run that exports it to PDF, to see if that helps. 

    And I have five other scheduled reports that are identical in format, fields, etc. (except for a different crew), and now that I think of it, only three of them have been running automatically for a while, too! I've attached an .xls version of the exported report so you can see what I'm generating.

    Thanks again for the comments and any suggestions that might come of the discussion.

    ------------------------------
    Amy Briggs
    Maintenance Planner
    The Jackson Laboratory
    Bar Harbor, ME
    207-288-6356
    ------------------------------

    Attachment(s)

    xlsx
    071620.xlsx   39K 1 version


  • 4.  RE: BMXAA5480E-Report run error

    Posted 07-16-2020 09:07

    Thanks for the reference as that helps. That definitely eliminates the HTML element from the equation. It looks like a pretty standard QBR report, which makes it all the more strange as it doesn't seem like something we've seen and we had a lot of customers on 7.6.0.6 (most are now on newer versions though).

    I found a few APARs, such as a query only providing an order by (APAR https://www.ibm.com/support/pages/apar/IV94203 & https://www.ibm.com/support/pages/apar/IV90466), but both of those look like that should fail when you run it interactively and your run time where clause didn't have an order by. I haven't been able to find anything else yet and I've looked through the fixes for 7.6.0.7, 7.6.0.8, & 7.6.0.9. 

    This unfortunately may end up requiring a case with IBM as it might get into environment specific configuration which is a bit tricky to troubleshoot. 



    ------------------------------
    Steven Shull
    Projetech
    ------------------------------



  • 5.  RE: BMXAA5480E-Report run error

    Posted 07-17-2020 08:44
    Thanks, Steven. I was trying to avoid opening up a case with IBM, but it sounds like that's the next step. Thank you for taking the time to check this out and offer your feedback.

    -Amy

    ------------------------------
    Amy Briggs
    Maintenance Planner
    The Jackson Laboratory
    Bar Harbor, ME
    207-288-6356
    ------------------------------



  • 6.  RE: BMXAA5480E-Report run error

    Posted 07-17-2020 21:55
    Hi Amy,

    Mu suggestion is running the scheduled report with Report and cron logger on. It will give you the details of what is going wrong. Like did the report fail while connecting to the db or while running the report query or while converting the report data into XLS.
    You would need access to Maximo log files and expertise to read and understand Maximo logs and BIRT report logs.

    Thanks,
    Biplab

    ------------------------------
    Biplab Choudhury
    Tata Consultancy Services
    ------------------------------