Maximo Open Forum

 View Only

 Remove LDAP authentication from Maximo

Jump to Best Answer
  • Administration
  • Security
Ajay Kotapati's profile image
Maximo Certified Ajay Kotapati posted 11-23-2021 23:48
Hi All,

We have Maximo 7.6.0 and Websphere 8 environment with LDAP authentication.
We would like to remove LDAP authentication and I have to use Maximo authentication so we would like to know what are the steps we have to take to remove LDAP authentication from Maximo.

let me know if you have any technote to remove LDAP authentication from Maximo.

Any guidance would be appreciated.
Prashant Sharma's profile image
Prashant Sharma Best Answer
\ibm\smp\maximo\applications\maximo\maximouiweb\webmodule\WEB-INF\web.xml
search for the <security-constraint> tag and comment to the bottom of </login-config> as seen below
<login-config>
<auth-method>BASIC<auth-method>
</login-config>

Ensure <login-config><auth-method>FORM<auth-method> is uncommented

In same file revert useAppServerSecurity to 0.

In maximo system properties mxe.useAppServerSecurity set to 0 which is 1 right now.

Repeat the above step without the the auth-method in the following 3 web.xml files – that is, uncomment the <security-constraint> sections and change useAppServerSecurity=1:
.\IBM\SMP\maximo\applications\maximo\mboweb\webmodule\WEB-INF
.\IBM\SMP\maximo\applications\maximo\meaweb\webmodule\WEB-INF
.\IBM\SMP\maximo\applications\maximo\maxrestweb\webmodule\WEB-INF

Go to Websphere > Enterprise Application > Maximo > Security Role to user/group mapping >
Remove mapped group/user and mapping realm “All Authenticated in Applications realm”.
Deploy the EAR.
Disable VMMSYNC cron.
Jason Uppenborn's profile image
Maximo Certified Jason Uppenborn
If you can't log in after performing Prashant's answer, make sure you don't have mxe.useAppServerSecurity=1 in your maximo.properties. If this is your problem, remember to set the maximouser role mapping back to Special subject Everyone during or after your deployment.