Maximo Open Forum

 View Only

 Eclipse and BIRT 4.3.1 configuration on Mac

  • Reporting
Stewart Lawrence's profile image
Stewart Lawrence posted 01-17-2022 03:16
Hi Folks

New to this forum; thanks for the admission. Not new to Maximo nor Eclipse / BIRT, but haven't struck the issue before, though it is a while since I have set up Eclipse on any platform.

I am attempting to set up Eclipse Kepler with BIRT on my MacBook Air. I have followed the instructions from IBM for Mac / Linux, however, when I attempt to "Install new software" I am receiving the error below:

Unable to read repository at http://download.eclipse.org/releases/kepler/content.xml.

peer not authenticated

I can navigate to the repository using a browser, but I am met with a message that implies it is for access by the Kepler application and not for general browsing. 

I have used two separate internet connections, but with no success.

Does anyone have a solution to this; or even some out-there suggestions?

Thanks

Regards

Stewart

Prashant Sharma's profile image
Maximo Certified Prashant Sharma
Hi Stewart

Have you tried deleting the Eclipse cache? Where eclipse is installed go to that folder and try following-

  • Deleting the cache directory \eclipse\p2\org.eclipse.equinox.p2.repository\cache
  • Refreshing the repositories.
    • Preferences -> Install Update -> Available Software Sites => select the entry
    • Click the "Reload"

Thanks,
Prashant
Stewart Lawrence's profile image
Stewart Lawrence

Hi Prashant

Thanks so much for your suggestion. Apologies that it has taken so long for me to swing back. I couldn't find a way to respond to you directly.

I have tried your suggestion. I did not have a ~p2.repository directory. I did have a cache directory under the ~p2.core directory which I deleted, but still with no good result.

The error message says that it can not read the content.xml repository file. Could this be an issue with the correct JDK or Java Runtime? I have also tried to do the updates and receive similar responses. Could it be that these repositories simply don't exist any more? I have visited the website with a browser, but that doesn't let me in. The URL exists, but gives the message that this is normally accessed via the Eclipse tool.

Any other suggestions would be appreciated. Te recap, this is Eclipse Kepler 4.3.1 for BIRT report development.

Thanks

Regards

Stewart