Maximo Open Forum

 How do I format an ad-hoc report created in Maximo for PDF Print without cutting off the data on the right-hand side?

  • Reporting
posted 01-06-2021 12:53
This is probably a minor question, but it is causing grief so I'm asking humbly in search of guidance. 

We  have multiple AD-Hoc reports created in Maximo (version  Cloud) and exporting to PDF for printing always seems to cut off the right-hand columns of data.  What am I missing when setting up the report within Maximo? Is there an option to size columns to the page? (similar to an Excel printing option?) 

Or, do I need to export the file to BIRT Designer (or similar?) in order to format correctly for PDF printing? 

Thank you!
Maximo Certified
One thing you can control is whether it's portrait or landscape, so hopefully on these reports you've chosen landscape to increase the available width. But beyond that in QBR you can't get this level of control on the PDF export. You would need to export to BIRT to adjust column sizes to avoid it exceeding the page size. Be aware though that someone changing the QBR will cause it to be recreated so your changes would be lost. I'd recommend saving it under a different name to avoid that from occurring.
I had this issue. Some times, the number of columns you have in your report, push the report off the page if you leave PRINT FORMAT in "Auto".

I have resorted to selecting ACTUAL SIZE, and this works, IF the report is not going to be multiple pages. I have had issues with the page orientation changing from landscape to portrait, which makes for interesting comments from your audience.

Projetech finally told me that there is an issue with .pdf in Maximo. If my report is multiple pages, I've chosen the "Export Report" option > ELS Emitter Format to get my report is a usable format. Then use Excel's pdf option.

I hope this helps,

@Steven Shull @Lynn Bradford  Thank you both for your suggestions.  I'll likely use the export report option or just use a BIRT to create a new one - I appreciate the insight!​​