MxLoader

 View Only
  • 1.  Unable to load attachments from IBM MAXIMO library to ASSETs.

    Posted 04-20-2022 08:53

    Hello everyone, 
    Here is mine object structure:

    The goal was to upload attachments/files from library to assets, but I keep getting this error:

    Internal Server Error
    Error 500: BMXAA4214E - An unknown error has occurred. Please contact your system administrator for assistance.
    Gather the logs from the <HOME> directory and determine where and why the error occurred.

    null

    Need to mention, that two months ago this loader worked. Other loaders or object structures works just fine. 

    Can anyone spot some kind of an error? 
    Object structure is: ASSET/DOCLINKS/DOCTYPES.
    Can it be somehow related to the database? Few weeks ago there was a need to put on backup copy of DB. 

    Thanks everyone for the help!  



    ------------------------------
    Matis Dovydas
    ------------------------------


  • 2.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Maximo Certified
    Posted 04-22-2022 23:20
    Hi Matis have you checked the logs ? The logs will clearly tell you what happened. This unknown error is very generic and will be difficult to troubleshoot without logs. Please paste logs.

    Thanks
    Venkat

    ---------------------------------
    Thanks & Regards
    Venkat
    ---------------------------------





  • 3.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Posted 16 days ago

    Can anyone show how Object Structure should look for this kind of task? And MX_Loader too. 

    I just can't figure it out. 



    ------------------------------
    Matis Dovydas
    ------------------------------



  • 4.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Maximo Certified
    Posted 14 days ago
    Hi Matis, 
    Here is what our Object Structure looks like. All we added was the DOCLINK with the out of the box DOCLINKS relationship.
    ObjectStructure
    Here is our MxLoader sheet. There is no OWNERID field in the asset table.
    MxLoader


    ------------------------------
    Adam Ames
    Kwik Trip, Inc.
    ------------------------------



  • 5.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Posted 9 days ago

    Hi Adam! 

    Thank you for your response. I appreciate.
    This works only with the file/attachment which physical path is locally on computer. 
    My queastion was about how to bulk add file or attachement from IBM MAXIMO library ('Manage Library') to assets with MxLoader. 
    I have the same object structure. Yaay! 
    Few weeks ago this worked, but suddenly stoped working:


    Is there anything else to look at?



    ------------------------------
    Matis Dovydas
    ------------------------------



  • 6.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Maximo Certified
    Posted 8 days ago
    Hi Matis,
    Our attachments are stored on a network shared drive not locally so it should work whether the attachment is stored locally or wherever you are storing the IBM Maximo library. Weird that it would stop working. I believe in the MxLoader documentation that you do need to include the FileEnc:/ before your url path.

    Adam

    ------------------------------
    Adam Ames
    Kwik Trip, Inc.
    ------------------------------



  • 7.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Posted 7 days ago
    Hello, 

    Okay, looks like there is more than one way how to add files/attachments from library to records/assets. 

    I don't know how, but now I managed to upload file to assets, but when they are uploaded, the name has changed with ID (numbers). For example text.txt and after upload text12345678.txt and it shows me an error -> Not Found. The requested URL /Attachment/text1652965293245.txt was not found on this server. IBM_HTTP_Server Server at <....> Port 443

    ------------------------------
    Matis Dovydas
    ------------------------------



  • 8.  RE: Unable to load attachments from IBM MAXIMO library to ASSETs.

    Maximo Certified
    Posted 3 days ago
    Hi Matis,
    Can you show me the MxLoader sheet you used that caused this last issue?

    Thank you,
    Adam

    ------------------------------
    Adam Ames
    Kwik Trip, Inc.
    ------------------------------